Sophos Notification: Sophos Email

Performance
July 12, 11:26pm UTC

Sophos Notification: Sophos Email

Status: closed
Start: July 12, 5:39pm UTC
End: July 12, 11:26pm UTC
Duration: 5 hours 47 minutes
Affected Components:
Status page components Sophos Central Products Grid Components Central - Sophos Email Central - Sophos Mail Canada (CA-Central-1) Germany (EU-Central-1) Ireland (EU-West-1) Ohio (US-East-2) Oregon (US-West-2)
Update

July 12, 5:39pm UTC

July 12, 5:39pm UTC

Sophos Notification: Important information about Sophos Email, please check: https://soph.so/5dsjQn
Unsubscribe at https://sophoscentral.status.page

Resolved

July 12, 11:26pm UTC

July 12, 11:26pm UTC

Sophos Notification: Important information about Sophos Email, please check: https://soph.so/5dsjQn
Unsubscribe at https://sophoscentral.status.page