Sophos Notification System

Informational
May 24, 6:07pm UTC

Sophos Notification System

Status: closed
Date: May 24, 6:06pm UTC
Affected Components:
Status page components Sophos Central Products Non-Grid Components Grid Components Central - Phish Threat Phish Threat
Update

May 24, 6:06pm UTC

May 24, 6:06pm UTC

Sophos Notification: Important information about Phish Threat, please check: https://soph.so/Ez2BEA
Unsubscribe at https://sophoscentral.status.page

Update

May 25, 6:35pm UTC

May 25, 6:35pm UTC

Incident regarding customer level Phish Threat campaigns not being visible from the Partner Dashboard is now resolved